1
$\begingroup$

Not sure if this question is more appropriate for StackOverload, but I'm guessing a bunch of people here have experience with MPI2, so thought I would try here first. I have some large dense complex symmetric matrices that I would like to factor and wanted to try out Elemental for its MPI support. I compiled Open MPI 1.8.1 and a simple "hello world" example, but for some reason when I try to run: mpirun -n 2 -host localhost,machine-2 hello_world it just exits without outputting anything or even starting the hello_world program. If I run it on just localhost (i.e. mpirun -n 2 -host localhost hello_world), it works just fine. Do you use Open MPI or a different flavor of MPI2? I've searched everywhere online and can't find a working solution or even just a cause for this problem. (I have ssh setup between all the machines such that I do not need to use a password.) The machines are running RedHat 5, and I do not have root access to them. I have read that it might be a firewall problem (what ports does OpenMPI use outside of ssh?). Do I need to have anything placed in /etc/hosts? Thanks so much in advance!

$\endgroup$
  • 5
    $\begingroup$ Sounds like an environment problem, but the best forum (if you want answers from the Open MPI developers) is to ask on their mailing list. $\endgroup$ – Jed Brown Jul 23 '14 at 5:12
  • $\begingroup$ I just compiled MPICH2 and tried that instead. It also fails but gives me more of an error description (rather than just exiting): [proxy:0:1@machine-2] HYDU_sock_connect (../../../../src/pm/hydra/utils/sock/sock.c:172): unable to connect from "machine-2" to "localhost" (Connection refused) [proxy:0:1@machine-2] main (../../../../src/pm/hydra/pm/pmiserv/pmip.c:189): unable to connect to server localhost at port 51882 (check for firewalls!) $\endgroup$ – Costis Jul 23 '14 at 10:20
  • 1
    $\begingroup$ Please use the Google: stackoverflow.com/questions/20018954/… Also, please upgrade MPICH to the latest stable version. And if you have further configuration questions, ask them on the mpich-discuss mailing list. $\endgroup$ – Jed Brown Jul 23 '14 at 15:19

Browse other questions tagged or ask your own question.