3
$\begingroup$

The library itself compiles just fine with icc, but when I try to link to it (using icc for both the driver code and the linker), I get the same error that this question on stackoverflow is asking about.

I've heard that gsl is very specific to the gnu compiler. Can gsl be compiled and linked to with icc? What about other compilers, like Clang?

$\endgroup$
4
$\begingroup$

We've built it with no problems with both GCC and the Intel compilers at TACC. According to ldd, libgsl.so is linked to libintlc.so which is the library that contains the SSE versions of the string routines. You might try explicitly linking to it with something like: -L/path/to/your/intel/libraries -lintlc.

$\endgroup$
  • $\begingroup$ Even explicitly linking doesn't work, I still get the same error. $\endgroup$ – Dan Jun 7 '12 at 21:32
  • $\begingroup$ Not having access to your machine makes this harder to debug. You might try: find /path/to/your/intel/libraries -name '*.so'| xargs nm -DA | grep __intel_sse2_strcpy and then link to the library that resolves the symbol (i.e. has a 'T' in the second column). $\endgroup$ – Bill Barth Jun 12 '12 at 1:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.