1
$\begingroup$

I would like to say first that am new at using Calculix.

I'm using Abaqus/CAE to create a cup deep drawing simulation and everything worked perfectly but my objective is to run the same exact simulation on Calculix and compare the results

So I used the same geometry and mesh and converted all the keywords from the input file of Abaqus to match the format of the input file for Calculix (it is a simple simulation so no big changes are made).

but when I run the CCX solver it stops at $t=0.09$ where the total time is $t=1$, and the error message is:

Too many cutbacks.

I tried:

  • refining the mesh of the slave part
  • lowering the initial time increment

I don't know where is the problem although it seems to me that is in the contact definition because every other thing defined is very simple (like mesh, boundary condition, and surface definition etc...) and no complicated parameters are needed.

This is how I defined the contact:

 ** contact 
 *Contact Pair, Interaction=SI1, Type=Surface To Surface
 Slave_tole, Master_poin
 *Surface Interaction, Name=SI1
 *Surface Behavior, Pressure-Overclosure=Linear
 1290000
 *Friction
 0.25, 350000

I used the same values as in the Abaqus simulation.

$\endgroup$
1
$\begingroup$

I'm not sure but the problem behind the contact: in Abaqus if the friction is bigger than 0.2 the solver using an unsymmetric matrix storage, however in the input file probably symmetric. So was overridden by the solver. But I don't know how is it working in calculix. But the input file should modify: UNSYMM=YES Check this:link it might be helpful. Let me know does it help.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.